Suche | Statistiken | Benutzerliste | Access-FAQ | Datenschutz Foren
donkarl Forum
donkarl Forum ->  Themen -> Access -> Diskussion ansehen

Du bist als Gast eingelogt. ( Anmelden | Registrieren )
  • JOIN
  • tina9030.04.14 20:36
       └ RE: JOIN Karl Donaubauer02.05.14 18:00
  • Fehlermeldung bei Klick
  • Greiff29.04.14 21:45
       └ RE: Fehlermeldung bei Klick Karl Donaubauer29.04.14 22:05
       └ unbefriedigend gelöst, Fehlermeldung bei Klick Greiff29.04.14 22:11
  • Abfrage per Fomular-Kombifeld aktualisieren?
  • VolkerWittmann24.04.14 17:25
       └ RE: Abfrage per Fomular-Kombifeld aktualisieren? Karl Donaubauer24.04.14 18:41
          └ RE: Abfrage per Fomular-Kombifeld aktualisieren? VolkerWittmann26.04.14 20:38
  • Access 2013 - Navigationsbereich ist leer
  • enchiriadis19.04.14 15:45
       └ RE: Access 2013 - Navigationsbereich ist leer enchiriadis20.04.14 19:46
  • Access 2010 Probleme mit Where-Condition
  • Matthias19.04.14 20:11
       └ RE: Access 2010 Probleme mit Where-Condition Matthias20.04.14 08:51
  • Zugriff auf Unterformular
  • georg586216.04.14 17:35
       └ RE: Zugriff auf Unterformular Karl Donaubauer16.04.14 18:13
          └ RE: Zugriff auf Unterformular georg586216.04.14 19:08
  • VBA Msgbox gibt nur einen Wert
  • hume15.04.14 16:26
       └ RE: VBA Msgbox gibt nur einen Wert Gunter Avenius16.04.14 08:56
  • Nicht ausreichende Systemressourcen
  • cdt_roger09.04.14 22:41
       └ RE: Nicht ausreichende Systemressourcen PeterDoering09.04.14 23:57
          └ RE: Nicht ausreichende Systemressourcen cdt_roger10.04.14 21:17
             └ RE: Nicht ausreichende Systemressourcen PeterDoering11.04.14 16:26
                └ RE: Nicht ausreichende Systemressourcen cdt_roger13.04.14 21:16
                   └ RE: Nicht ausreichende Systemressourcen PeterDoering13.04.14 23:48
                      └ RE: Nicht ausreichende Systemressourcen cdt_roger14.04.14 18:18
  • Öffentl. Formularmethode zur Entwicklungszeit
  • Georg M01.04.14 10:48
       └ RE: Öffentl. Formularmethode zur Entwicklungszeit Henry03.04.14 11:31
          └ RE: Öffentl. Formularmethode zur Entwicklungsz... Georg M14.04.14 09:59
  • Kennwort erforderlich
  • Cinibaba30.03.14 08:40
       └ RE: Kennwort erforderlich Greiff01.04.14 10:59
          └ RE: Kennwort erforderlich Cinibaba13.04.14 17:03
  • Formular-Recordset für Bericht verwenden
  • jojogar10.04.14 13:09
  • Access Stammtisch München am 10.04.2014 (Do)
  • StefanWirrer09.04.14 13:08
  • Funktion mit Parameter an Steuerelement übergeben
  • StefanWirrer04.04.14 11:04
       └ RE: Funktion mit Parameter an Steuerelement über... wilo05.04.14 17:50
          └ RE: Funktion mit Parameter an Steuerelement üb... StefanWirrer07.04.14 08:50
             └ RE: Funktion mit Parameter an Steuerelement ... wilo07.04.14 18:49
                └ RE: Funktion mit Parameter an Steuerelemen... StefanWirrer09.04.14 13:01
  • 2013er Datenbank mit Kennwort auch in 2010 und 200...
  • MiK08.04.14 19:28
  • SOAP Webservice mit VBA ansprechen
  • Axelander08.04.14 17:02
    VolkerWittmann
    Gesendet: 24.04.14 17:25
    Betreff: Abfrage per Fomular-Kombifeld aktualisieren?


    New user

    Beiträge: 2

    Hallo Access-Experten,

    kann ich eine Abfrage für einen WORD-Serienbrief irgendwie aktualisieren?

    Ausgangslage:
    1. Im Formular [frmKuProjAdrAuftr] wird per ungebundeenem Kombifeld [cboKundenID] ein Adressat ausgewählt.

    2. Per Me.Requery werden die sonstigen Felder im Formular [frmKuProjAdrAuftr] und den UFos [subfrmProjAuftr] und [subfrmAdressen] entsprechend der Kombifeld-Auswahl aktualisiert. Funktioniert soweit.

    3. In der Abfrage "qryWORDSerie" filtert mir das Kombifeld als Kriterium den gewünschten Datensatz. Funktioniert auch soweit.
    SELECT tblKunden.KundenID, tblKunden.Vorname, tblKunden.Nachname, tblProjekte.ProjektID, tblAuftrag.AuftragID, tblAdresse.AdressID
    FROM (tblKunden INNER JOIN tblAdresse ON tblKunden.KundenID = tblAdresse.KundenID)
    INNER JOIN (tblProjekte INNER JOIN tblAuftrag ON tblProjekte.ProjektID = tblAuftrag.ProjektID) ON tblKunden.KundenID = tblProjekte.KundenID
    WHERE (((tblKunden.KundenID)=[Formulare]![frmKuProjAdrAuftr]![cboKundenID]));

    4. Bei erstmaligem Aufruf steht auch tatsächlich der passende Datensatz als Ergebnis in der Abfrage. Funktioniert auch noch.


    Problem:
    Wähle ich jetzt im Kombifeld einen anderen Adressaten, dann kriege ich zwar das Formular aktualisiert, aber in der Abfrage bleibt der alte Datensatz aus dem erstmaligen Abfrage-Aufruf hängen.

    Me.Requery aktualisiert mir nur das Formular und CurrentDb.Execute "qryWORDSerie" liefert nur einen "Laufzeitfehler 3065" - Access mag meine Abfrage offensichtlich nicht per Execute neu abfragen.

    Wäre um einen Tipp dankbar, wie ich meinem Serienbrief am zweckmäßigsten einen aktuellen Datensatz bereitstellen könnte.

    Viele Grüße
    Volker


    Top of the page Bottom of the page


    Seite: < 43 44 45 46 47 48 ... 49 50 51 52 53 54 55 ... >
    Suche in diesem Forum
    Druckfreundliche Version
    (Alle Cookies von dieser Seite löschen.)