Suche | Statistiken | Benutzerliste | Access-FAQ | Datenschutz Foren
donkarl Forum
donkarl Forum ->  Themen -> Access -> Diskussion ansehen

Du bist als Gast eingelogt. ( Anmelden | Registrieren )
  • Export in Excel nur bestimmte Spalten
  • lengaumi13.01.14 12:06
       └ RE: Export in Excel nur bestimmte Spalten Karl Donaubauer13.01.14 18:25
          └ RE: Export in Excel nur bestimmte Spalten lengaumi13.01.14 21:38
             └ RE: Export in Excel nur bestimmte Spalten Karl Donaubauer14.01.14 12:35
                └ RE: Export in Excel nur bestimmte Spalten lengaumi17.01.14 14:20
                   └ RE: Export in Excel nur bestimmte Spalten Karl Donaubauer17.01.14 16:42
                      └ RE: Export in Excel nur bestimmte Spalten lengaumi17.01.14 21:28
                         └ RE: Export in Excel nur bestimmte Spalten Karl Donaubauer18.01.14 16:40
                            └ RE: Export in Excel nur bestimmte Spalten lengaumi20.01.14 16:36
                               └ RE: Export in Excel nur bestimmte Spalten Karl Donaubauer20.01.14 17:56
  • Farben
  • ManfredPrefi20.01.14 12:14
       └ RE: Farben StefanWirrer20.01.14 12:38
  • Performance analyse
  • csc10117.01.14 17:17
       └ RE: Performance analyse Karl Donaubauer17.01.14 18:06
          └ RE: Performance analyse csc10120.01.14 08:19
             └ RE: Performance analyse wilo20.01.14 09:32
  • Fehler abfangen und beheben
  • ManfredPrefi09.01.14 22:29
       └ RE: Fehler abfangen und beheben wilo10.01.14 10:21
          └ RE: Fehler abfangen und beheben ManfredPrefi10.01.14 18:01
             └ RE: Fehler abfangen und beheben wilo13.01.14 10:10
                └ RE: Fehler abfangen und beheben ManfredPrefi13.01.14 15:35
  • FindRecord kaputt
  • hochlenert12.01.14 16:57
       └ RE: FindRecord kaputt hochlenert13.01.14 02:58
  • Problem mit Me.RecordSource nach Umstellung auf A2...
  • Matthias09.01.14 14:48
       └ RE: Problem mit Me.RecordSource nach Umstellung ... Karl Donaubauer09.01.14 16:18
          └ RE: Problem mit Me.RecordSource nach Umstellun... Matthias09.01.14 20:00
             └ RE: Problem mit Me.RecordSource nach Umstell... Karl Donaubauer09.01.14 22:56
                └ RE: Problem mit Me.RecordSource nach Umste... Matthias10.01.14 10:38
  • wenn, dann; sonst
  • rdw09.01.14 15:56
       └ RE: wenn, dann; sonst Matthias09.01.14 20:12
  • Formulare synchronisieren
  • ManfredPrefi06.01.14 22:52
       └ RE: Formulare synchronisieren Karl Donaubauer07.01.14 12:32
          └ RE: Formulare synchronisieren ManfredPrefi07.01.14 21:13
  • Access Stammtisch München am 09.01.2014 (Do)
  • StefanWirrer07.01.14 10:13
  • Mailversand von Accerss
  • pwakolbi28.12.13 12:54
       └ RE: Mailversand von Accerss Greiff06.01.14 09:41
  • Typisierungsfehler bei Container-Objekt unterr Acc...
  • enchiriadis03.01.14 16:26
       └ RE: Typisierungsfehler bei Container-Objekt unte... Karl Donaubauer03.01.14 19:02
          └ RE: Typisierungsfehler bei Container-Objekt un... enchiriadis03.01.14 23:48
             └ RE: Typisierungsfehler bei Container-Objekt ... Karl Donaubauer04.01.14 17:10
                └ RE: Typisierungsfehler bei Container-Objek... enchiriadis05.01.14 18:28
  • FE mit BE verknüpfen
  • mikel03.01.14 09:53
       └ RE: FE mit BE verknüpfen pwakolbi03.01.14 11:51
       └ RE: FE mit BE verknüpfen Karl Donaubauer03.01.14 15:23
          └ RE: FE mit BE verknüpfen mikel04.01.14 14:33
  • Zugriff auf andere Datenbank
  • swetrain29.12.13 11:06
       └ RE: Zugriff auf andere Datenbank wilo02.01.14 17:35
  • Domain Problem
  • bkleine12.12.13 11:41
       └ RE: Domain Problem Karl Donaubauer12.12.13 12:57
  • UID Nummer automatisch überprüfen
  • Gearwheel06.12.13 13:55
       └ RE: UID Nummer automatisch überprüfen PeterDoering10.12.13 14:24
    ManfredPrefi
    Gesendet: 13.01.14 15:35
    Betreff: RE: Fehler abfangen und beheben


    Member

    Beiträge: 7

    Ort: Wallerfangen
    Hallo Wilo,

    danke für deine viele Mühe, aber auch der neue geänderte Text funktioniert nicht.
    Zunächst einmal rufe ich die Funktion aus einem eigens zum Testen angelegten Feld mit dem Funktionsaufruf DOCHECKS auf, um mich auf dieses Problem zu konzentrieren.
    Nach dem Aufruf kommt die Fehlermeldung VARIABLE NICHT DEFINIERT. Dabei wir auf den Eintrag 'DATUM' zwischen den beiden '&'-Zeichen verwiesen.

    Ich habe im Grunde mein Problem schon gelöst, allerdings in einem Klassenmudul als Ereignisprozedur eines besonderen Feldes 'SPEICHERN UND SCHLIESSEN'

    Dort lautet die Abfrage
    .......................
    ElseIf DCount("*", "TERMDET", "[DATUM] =" & "DATUM" & " and" & "[TITELNR] =" & TITELNR) > 0 Then
    ....................... usw
    und bringt immer das richtige Ergebnis.

    Beim umfangreichen Probieren (Learning bei Doing) hat sich herausgestellt: die Feldnamen in der Tabelle müssen in eckige Klammern gesetzt sein, und der Vergleichswert DATUM aus dem Formular muss in " " gefasst werden, offensichtlich, weil es sich um einen datum-formatierten Wert handelt; der numerische Vergleichswert TITELNR muss dagegen ohne Zeichen bleiben.

    Wenn ich diesen Text in die Funktion DOCHECKS eintrage, kommt zwar keine Fehlermeldung, aber das Ergebnis ist immer FALSE, auch wenn die entsprechenden Werte in der Tabelle nicht vorhanden sind.

    Eigentlich finde ich die Lösung mit einer Funktion besser, weil man sie von verschiedenen Stellen aus aufrufen kann und nicht in jedem Fall neu programmieren muß.

    Wenn du keine bessere Lösung hast, werde ich mal bei der jetzigen Methode bleiben.

    Herzliche Grüße


    Top of the page Bottom of the page


    Seite: < 40 41 42 43 44 45 ... 46 47 48 49 50 51 52 ... >
    Suche in diesem Forum
    Druckfreundliche Version
    (Alle Cookies von dieser Seite löschen.)