Mehrbenutzerumgebung DB korrupt nach 10 min bis 4 h
hochlenert
Gesendet: 14.08.18 08:57
Betreff: Mehrbenutzerumgebung DB korrupt nach 10 min bis 4 h


Member

Beiträge: 45
25
Hallo NG,
in einer Mehrbenutzerumgebung mit einem Backend und 1-10 Frontends kommt es seit einem ca. Monat dazu, das das backend nach kurzem Betrieb (zwischen 10 min und ca. 4 Stunden) korrupt wird.
Architektur: Das backend ist in Access 2007 programmiert und die frontends sind Access 2007 runtimes. Bei meinen Versuchen, das Problem zu lösen, habe ich auf drei Frontends die runtime auf die aktuelle Version gewechselt. Es sind 16 Tabellen verknüpft. Die erste Sicherung vor reparatur hatte 83 mb, die späteren 32 mb ca..
Bisherige Versuche:
1. Es gab ein Feld, das Abstürze verursachte. Der Datensatz wurde gelöscht. Die ganze Tabelle wurde als CSV-Datei exportiert und in eine neue Tabelle importiert.
2. Ich habe ein Frontend zum testen programmiert, das alle Felder in allen Datensätzen in Schleifen durchgeht und dabei den Inhalt kopiert, einen Eintrag macht, den abspeichert, das Feld wieder öffnet, den Originaleintrag reinschreibt und den wieder speichert. Dabei gibt es keine Abstürze oder korrupte Datenbanken.
3. Ich habe eine Archivfunktion programmiert, um das backend klein zu halten. Es hat jetzt 18 mb.
Die Datenbank ist auch an 100 andere Anwender verteilt, die keine Probleme haben. Das Phänomen tritt nur bei mir auf.
Ich weiß nicht mehr, was ich noch tun / versuchen könnte. Ich konnte keinen Auslöser feststellen. Es wirkt so, als ob es der Start eines zusätzlichen Frontends wäre, der die Korruption auslöst (oder auch nur aufdeckt?), nachdem seit der letzten Reparatur eine gewisse Zeit damit gearbeitet wurde.
Euer Dirk
Top of the page Bottom of the page