Suche | Statistiken | Benutzerliste | Access-FAQ | Datenschutz Foren
donkarl Forum
donkarl Forum ->  Themen -> Access -> Diskussion ansehen

Du bist als Gast eingelogt. ( Anmelden | Registrieren )
  • Mailversand per VBA
  • milo5813.02.15 13:20
       └ RE: Mailversand per VBA Gunter Avenius14.02.15 18:14
          └ RE: Mailversand per VBA milo5816.02.15 08:28
       └ RE: Mailversand per VBA Karl Donaubauer16.02.15 15:10
          └ RE: Mailversand per VBA milo5816.02.15 15:23
             └ RE: Mailversand per VBA Axelander23.02.15 11:51
  • Acc2010 - Contextual Tabs
  • Axelander23.02.15 11:38
  • Prameterabfrage mit Fehlermeldung 1325
  • U92E19.02.15 11:27
       └ RE: Prameterabfrage mit Fehlermeldung 1325 Karl Donaubauer20.02.15 13:19
          └ RE: Prameterabfrage mit Fehlermeldung 1325 U92E20.02.15 19:29
  • Access2013 zeigt die Beziehungen nicht mehr an
  • access2013beziehunge16.02.15 19:13
       └ RE: Access2013 zeigt die Beziehungen nicht mehr ... Karl Donaubauer17.02.15 12:06
  • alte mdw aktualisieren
  • StefanWirrer05.02.15 16:02
       └ RE: alte mdw aktualisieren StefanWirrer12.02.15 13:41
          └ RE: alte mdw aktualisieren Karl Donaubauer12.02.15 18:00
             └ RE: alte mdw aktualisieren StefanWirrer13.02.15 10:18
  • A2007 printout verursacht fehler 2052 (nicht genüg...
  • hochlenert10.02.15 08:56
       └ RE: A2007 printout verursacht fehler 2052 (nicht... Karl Donaubauer10.02.15 16:34
          └ RE: A2007 printout verursacht fehler 2052 (nic... hochlenert13.02.15 07:46
  • Access Stammtisch München am 12.2.2015 (Do)
  • StefanWirrer10.02.15 08:51
  • Langsamer Formularaufbau
  • HQbauer30.01.15 00:46
       └ RE: Langsamer Formularaufbau HQbauer30.01.15 15:47
          └ RE: Langsamer Formularaufbau Karl Donaubauer02.02.15 13:45
             └ RE: Langsamer Formularaufbau HQbauer03.02.15 12:46
                └ RE: Langsamer Formularaufbau HQbauer05.02.15 07:03
  • Mehre Tabellen in einem Formula
  • U92E02.02.15 13:43
       └ RE: Mehre Tabellen in einem Formula Karl Donaubauer02.02.15 13:58
          └ RE: Mehre Tabellen in einem Formula U92E02.02.15 14:25
             └ RE: Mehre Tabellen in einem Formula Karl Donaubauer02.02.15 15:06
       └ RE: Mehre Tabellen in einem Formula U92E02.02.15 15:35
       └ RE: Mehre Tabellen in einem Formula U92E04.02.15 19:10
  • SQL Findet Tabelle nicht
  • U92E03.02.15 14:24
       └ RE: SQL Findet Tabelle nicht Karl Donaubauer03.02.15 15:42
       └ RE: SQL Findet Tabelle nicht U92E03.02.15 17:01
          └ RE: SQL Findet Tabelle nicht Karl Donaubauer03.02.15 20:34
  • nicht erkennbares Datenformat
  • Helmut03.02.15 09:30
  • A 2007 zweistelliges Feld befüllt leere Stellen mi...
  • hochlenert26.01.15 14:43
       └ RE: A 2007 zweistelliges Feld befüllt leere Stel... Karl Donaubauer26.01.15 14:53
          └ RE: A 2007 zweistelliges Feld befüllt leere St... hochlenert26.01.15 18:31
  • ACC03 mit ADO - unerwünschte Konvertierung Zeichen
  • Christian Kehl22.01.15 11:07
  • Aktionsabfrage - mehrfache Ausführung
  • bhausu19.01.15 19:46
       └ RE: Aktionsabfrage - mehrfache Ausführung wilo20.01.15 11:08
          └ RE: Aktionsabfrage - mehrfache Ausführung bhausu20.01.15 14:10
  • Vortrag zu Ribbons beim Access-Stammtisch Rhein-Ma...
  • Martin Asal16.01.15 20:02
    bhausu
    Gesendet: 19.01.15 19:46
    Betreff: Aktionsabfrage - mehrfache Ausführung


    Member

    Beiträge: 11

    Hallo Forum, hallo DonkarlTeam,
    mal wieder ein super Problem, echt schwierig für mich.. vielleicht kennt ja einer von euch eine Lösung?

    Hab ein Problem mit einem Formular für eine Organisationsdarstellung (Organigramm).
    Da drin ist ein Treeview-Objekt, welches auch ganz gut funktioniert.
    Durch Klicken eines Buttons wird folgende Prozedur ausgelöst..

    Private Sub Befehl12_Click()
    'Prüfen, welche OE markiert ist..

    Dim intOE As Integer
    Dim strOEName
    Dim strSQLadd As String

    intOE = Mid(m_Treeview1.SelectedItem.Key, 2)
    strOE = InputBox("Wie heißt die neue Organisationseinheit?", "Frage")

    strSQLadd = "INSERT INTO tblOrganisation ( txt_Orgdescr, intParentOrg ) " & _
    " SELECT '" & strOE & "' AS New1, " & intOE & " AS New FROM tblOrganisation;"

    Set db = CurrentDb
    db.Execute strSQLadd
    Set db = Nothing

    End Sub

    Funktioniert.. allerdings zu gut :-) die Abfrage fügt nicht EINEN Datensatz an, sondern irgendwas zwischen 5 und 12 identische Datensätze (die Anzahl ist jedesmal unterschiedlich).
    Was steckt da dahinter? Wer weiß was?
    Vielen Dank für eure Ideen im Voraus..
    Viele Grüße, Bernd
    Top of the page Bottom of the page


    Seite: < 28 29 30 31 32 33 ... 34 35 36 37 38 39 40 ... >
    Suche in diesem Forum
    Druckfreundliche Version
    (Alle Cookies von dieser Seite löschen.)