Suche | Statistiken | Benutzerliste | Access-FAQ Foren
donkarl Forum
donkarl Forum ->  Themen -> SQL Server -> Diskussion ansehen

Du bist als Gast eingelogt. ( Anmelden | Registrieren )
  • SQL Server 2016 kompatibel mit Windows 7 und MS Ac...
  • alexander08.06.17 07:45
       └ RE: SQL Server 2016 kompatibel mit Windows 7 und... PeterDoering06.08.17 22:31
  • Abfangen Fehlermeldung bei Unterbrechung Serverver...
  • Fuchskusu02.09.16 09:17
       └ RE: Abfangen Fehlermeldung bei Unterbrechung Ser... Karl Donaubauer14.09.16 15:47
  • Clustered index update
  • Marzer24.05.16 06:41
       └ RE: Clustered index update Marzer25.05.16 11:01
       └ RE: Clustered index update uricken31.05.16 11:21
  • Access Frontend .adp in ein neues Verzeichnis vers...
  • willi15409.12.15 14:20
       └ RE: Access Frontend .adp in ein neues Verzeichni... willi15410.12.15 12:57
          └ RE: Access Frontend .adp in ein neues Verzeich... PhilS10.12.15 15:18
  • SQL Server 2014
  • manfri08.05.15 13:40
       └ RE: SQL Server 2014 PeterDoering10.05.15 09:47
  • Probleme bei gespeicherter Procedur
  • pwakolbi16.12.14 11:05
       └ RE: Probleme bei gespeicherter Procedur StefanWirrer17.12.14 13:21
          └ RE: Probleme bei gespeicherter Procedur PeterDoering29.12.14 14:52
       └ RE: Probleme bei gespeicherter Procedur PeterDoering24.12.14 13:47
          └ RE: Probleme bei gespeicherter Procedur pwakolbi29.12.14 09:36
  • Superbase
  • Gearwheel14.11.14 14:04
       └ RE: Superbase PeterDoering23.11.14 09:16
  • Select wird langsamer, wenn Variable als Parameter...
  • Christian Kehl19.11.13 11:55
       └ RE: Select wird langsamer, wenn Variable als Par... PeterDoering11.12.13 12:17
          └ RE: Select wird langsamer, wenn Variable als P... Christian Kehl02.01.14 15:04
             └ RE: Select wird langsamer, wenn Variable als... uricken20.07.14 17:34
                └ RE: Select wird langsamer, wenn Variable a... Christian Kehl18.08.14 17:01
  • Migration nach SQL
  • SoftHAK07.01.14 12:01
       └ RE: Migration nach SQL PeterDoering01.03.14 01:03
  • Neues Buch zum Thema "Migration Access nach S...
  • Bernd Jungbluth23.12.13 12:42
       └ RE: Neues Buch zum Thema "Migration Access ... Karl Donaubauer23.12.13 14:46
  • Tabellen beim Einbinder der SQL Tabellen fehlen
  • Ramftel27.09.13 12:41
       └ RE: Tabellen beim Einbinder der SQL Tabellen feh... PeterDoering11.12.13 12:25
  • Stücklistenauflösung
  • Raimo09.10.13 16:20
       └ RE: Stücklistenauflösung vllt. OT (.Net) Raimo05.12.13 10:47
  • AdHoc-Abfrage auf passwortgeschützte Excel-Datei
  • CuLi13.06.12 16:08
       └ RE: AdHoc-Abfrage auf passwortgeschützte Excel-D... Henry01.07.13 09:49
  • SSRS Domainproblem
  • Isolde09.06.13 17:05
  • SQL Server status runnable einer View
  • psl27.05.13 11:15
       └ RE: SQL Server status runnable einer View PeterDoering27.05.13 11:50
          └ RE: SQL Server status runnable einer View psl27.05.13 15:01
             └ RE: SQL Server status runnable einer View PeterDoering27.05.13 20:28
    pwakolbi
    Gesendet: 16.12.14 11:05
    Betreff: Probleme bei gespeicherter Procedur


    Member

    Beiträge: 43
    25
    Ort: Mauerbach bei Wien
    Guten Morgen!

    Beim Filtern in einer gespeicherten Procedur klappt der Filter nicht

    Ich möchte
    Wenn @Lieferant 0 ist sollen alle Lieferanten angezeigt werden
    ansonsten nur der Lieferant,


    ALTER Procedure [dbo].[spProdukteFilter]
    @Artikel varchar(50)='%',
    @Rabatt varchar(16)='%',
    @Warengruppe varchar(16)='%',
    @Lieferant int=0

    AS
    SELECT * FROM tblProdukt
    WHERE

    if @Lieferant=0
    tblProdukt.Lieferant) >= @Lieferant)AND
    ELSE
    ((tblProdukt.Lieferant) =@Lieferant) AND
    -- Weitere Filter.


    Mit meinen if Else construckt bekomme ich folgene Fehlermeldung:

    Meldung 156, Ebene 15, Status 1, Prozedur spProdukteFilter, Zeile 41
    Falsche Syntax in der Nähe des if-Schlüsselworts.
    Meldung 102, Ebene 15, Status 1, Prozedur spProdukteFilter, Zeile 42
    Falsche Syntax in der Nähe von 'tblProdukt'.

    Das Problem tritt nur beim Lieferanten auf. Bei den anderen Filtern kein Problem.
    Besten Dank im Voraus für einen tipp!

    LG
    Peter

    Top of the page Bottom of the page


    Seite: 1 2 3
    Suche in diesem Forum
    Druckfreundliche Version
    (Alle Cookies von dieser Seite löschen.)