TreeView-Problem unter A10
StefanWirrer
Gesendet: 05.09.12 17:22
Betreff: TreeView-Problem unter A10


Veteran

Beiträge: 264
1001002525
Ort: München

Hallo,

ich habe seit letzter Woche ein Problem mit einem FE.

Ich entwickle unter Win XP und A03.
Die FE's laufen unter Win XP mit A03 oder A10 oder unter Win 7 (64) mit A10 (32).
Alles aktuell, aber ohne dem bösen Office-Sicherheitsupdate.

Die Fehlermeldung
Sie haben als Einstellung der Ereigniseigenschaft den Ausdruck Click [oder anderes Ereignis] eingegeben. Dieser Ausdruck hat einen Fehler verursacht: Fehler beim Versuch, ein ActiveX-Steuerelement in eines Ihrer Formulare oder einen Ihrer Berichte zu laden.

* Der Ausdruck gibt möglicherweise weder den Namen eines Makros noch den Namen einer benutzerdefinierten Funktion noch [Ereignisprozedur] zurück.

* Beim Auswerten einer Funktion, eines Ereignisses oder eines Makros trat möglicherweise ein Fehler auf.


tritt bei 2 Anwendern mit A10 (und Notebook) auf.
Bei 3 anderen Anwendern mit A10 (PC) tritt der Problem nicht auf.

Die Treeviews in anderen FE's sind nicht betroffen.


Meine erfolglosen Reparaturversuche:
- Formular neu importieren (OASIS)
- Compilieren und Reparieren
- TV löschen und neu anlegen
- decompile
- Formular löschen und neu anlegen

Was beim Anwender hilft:
Formular öffnen, TV auschneiden und dann wieder einfügen.
Dann funktioniert der Treeview.

Das Importieren des lokalen Formulars in das zentrale FE hilft auch nicht. Beim gleichen Anwender tritt das Problem wieder auf.

Der genannte Workaround ist keine Lösung, da die FE's geschützt sind und der normale Anwender nicht's an den Objekten ändern kann.
Außerdem müßte ich dann nach jedem Update von User zu User marschieren.

Hat jmd. eine Lösung?


-----
Grüße aus München
Stefan
Top of the page Bottom of the page