Access XP - merkwürdige CPU Auslastung
Mario Nestelberger
Gesendet: 19.10.11 18:23
Betreff: neue Zusammenfassung - vielleicht hat jemand noch eine Idee


Member

Beiträge: 37
25
Habe mir gedacht ich fasse die Problematik einmal zusammen, vorallem da im ersten Posting ein Fehler unterlaufen ist, und ich neue Erkenntnisse habe. Vorweg, ich bin für jede (auch kostenpflichtige Hilfe) dankbar.

Wie schon gepostet, mir ist vor einiger Zeit aufgefallen, dass das Frontend auf einem Kundenrechner bei gewissen Formularen eine CPU Last von 100 % erzeugt.

Nachdem ich gleich darauf den selben Effekt bei einem anderen Kunden hatte (Dual Core, 50 % Auslastung) begann ich auf 3 Rechnern zu analysieren:

PC1: mein Entwicklungsrechner: WinXP Pro, Access XP Dev, Fehler tritt nicht auf
PC2 (Notebook): WinXP Home, Access XP Dev - Fehler tritt auf
PC3: WinXP Pro, XP Runtime - Fehler tritt nicht auf (war im ersten Posting falsch)

Habe dann ältere Programmversionen getestet, ab März 2011 habe ich den Effekt wie beschrieben, ich habe seitdem jedoch nichts wirklich entscheidendes geändert.

Einzige Besonderheit sind 2 Verweise (die gab es vorher auch schon): Verweise auf Internet Controls und Soap Toolkit 3.0

Nach weiteren Tests, der Effekt tritt auf rund 2/3 Drittel der Rechner auf (unabhängig von der Windows Version, jedoch vermehrt auf Home Versionen)

Anfangs habe ich geglaubt, dass Decompilieren am jeweiligen System hilft, dürfte aber ein Fehlversuch gewesen sein.

Meine jetzige Abhilfe: Access 2010 Runtime, gleiches Frontend, klappt auf jedem System, alles läuft wie es soll.

Anfangs dachte ich weiter, dass es sich doch um einen versteckten Programmierfehler handelt, da der Effekt beim Öffnen des ersten ungebundenen Formulares noch nicht auftritt, habe dann aber bemerkt, dass zb. auch der VBA Editor hängt, einzelne Formulare auch im Entwurfsmodus nur sehr stark zeitverzögert auf Verschieben von Steuerelementen reagieren.

http://support.microsoft.com/kb/160819/de schließe ich deshalb aus (habe ich schon vor dem Posting gekannt), Objektnamen Autokorrektur habe ich auch schon wie vorgeschlagen ausgeschaltet, selber Effekt.

Habe jetzt auch noch Jet Version kontrolliert, und weiters überprüft ob es in dem Zeitraum einen Patch gegeben hat, ich habe jedoch nichts gefunden.

Sysinternals Prozess Explorer ergibt eindeutig, dass die die msaccess.exe die die Systemauslastung erzeugt.

Vielleicht hat doch noch jemand eine Idee.
Top of the page Bottom of the page