Suche | Statistiken | Benutzerliste | Access-FAQ | Datenschutz Foren
donkarl Forum
donkarl Forum ->  Themen -> Access -> Diskussion ansehen

Du bist als Gast eingelogt. ( Anmelden | Registrieren )
  • Abfrageproblem
  • Greiff24.05.17 13:22
       └ RE: Abfrageproblem Karl Donaubauer25.05.17 11:21
          └ RE: Abfrageproblem Greiff29.05.17 00:33
             └ Problem gelöst Greiff30.05.17 23:40
  • Bedingte Formatierung
  • Marzer24.05.17 09:46
       └ RE: Bedingte Formatierung Karl Donaubauer24.05.17 10:49
          └ RE: Bedingte Formatierung Marzer24.05.17 11:21
  • Abbruch nach Laufzeitfehler
  • waholin22.05.17 09:26
       └ RE: Abbruch nach Laufzeitfehler Greiff23.05.17 09:20
          └ RE: Abbruch nach Laufzeitfehler waholin23.05.17 09:55
  • Steuerelement-Rahmen bei Focuserhalt
  • waholin19.05.17 09:43
  • Unterformular über mehrere Tabellen steuern
  • Hasslrob15.05.17 14:48
       └ RE: Unterformular über mehrere Tabellen steuern Karl Donaubauer15.05.17 17:36
          └ RE: Unterformular über mehrere Tabellen steuern Hasslrob15.05.17 19:46
             └ RE: Unterformular über mehrere Tabellen steuern Karl Donaubauer16.05.17 11:36
                └ RE: Unterformular über mehrere Tabellen st... Hasslrob17.05.17 22:00
  • VBL Code anpassen ...
  • LKro197612.05.17 16:15
       └ RE: VBL Code anpassen ... PeterDoering14.05.17 23:17
          └ RE: VBL Code anpassen ... LKro197617.05.17 17:47
  • Einladung zum 27. Access-Stammtisch Hannover am 17...
  • KlausWerther15.05.17 20:38
       └ RE: Einladung zum 27. Access-Stammtisch Hannover... KlausWerther16.05.17 09:29
  • tooltip
  • waholin15.05.17 14:00
       └ RE: tooltip Karl Donaubauer15.05.17 17:27
          └ RE: tooltip waholin16.05.17 07:27
          └ RE: tooltip waholin16.05.17 07:29
       └ RE: tooltip PeterDoering15.05.17 23:39
  • mehrere Steuerelemente auf einmal disabeln
  • waholin15.05.17 13:44
       └ RE: mehrere Steuerelemente auf einmal disabeln Karl Donaubauer15.05.17 14:05
          └ RE: mehrere Steuerelemente auf einmal disabeln waholin15.05.17 14:25
  • Ausgabe mit Transfertext erzeugt manchmal Fileläng...
  • Greiff05.05.17 16:25
       └ TransferText: neue Beobachtung Greiff09.05.17 11:21
          └ RE: TransferText: neue Beobachtung sks11.05.17 11:38
             └ RE: TransferText: neue Beobachtung PeterDoering11.05.17 14:36
             └ gelöst Greiff11.05.17 22:48
  • Access 2010 - Gespeicherte Importe (Datentask) nac...
  • LKro197611.05.17 16:03
       └ RE: Access 2010 - Gespeicherte Importe (Datentas... PeterDoering11.05.17 16:25
          └ RE: Access 2010 - Gespeicherte Importe (Datent... LKro197611.05.17 17:38
  • Optionsfeld - Farbe bei Aktivierung ändern
  • waholin09.05.17 10:58
       └ RE: Optionsfeld - Farbe bei Aktivierung ändern Karl Donaubauer09.05.17 12:38
          └ RE: Optionsfeld - Farbe bei Aktivierung ändern waholin09.05.17 18:31
  • Formulargröße Access-Fenster?
  • waholin04.05.17 18:04
       └ RE: Formulargröße Access-Fenster? Karl Donaubauer05.05.17 12:23
          └ RE: Formulargröße Access-Fenster? waholin08.05.17 08:47
             └ RE: Formulargröße Access-Fenster? Karl Donaubauer08.05.17 14:33
                └ RE: Formulargröße Access-Fenster? waholin09.05.17 08:04
  • Access Stammtisch München am 13.04.2017 (Do)
  • StefanWirrer11.04.17 12:45
  • TOP 20 der ID
  • dreho28.03.17 19:37
       └ RE: TOP 20 der ID Karl Donaubauer28.03.17 23:09
          └ RE: TOP 20 der ID dreho29.03.17 00:07
             └ RE: TOP 20 der ID Karl Donaubauer29.03.17 18:12
             └ RE: TOP 20 der ID PeterDoering30.03.17 01:05
    Greiff
    Gesendet: 29.05.17 00:33
    Betreff: RE: Abfrageproblem


    Veteran

    Beiträge: 170
    1002525
    Ort: Badendorf
    Hallo,
    1) ja, genau mit der geposteten Abfrage (ohne WHERE-Klausel) in der Datenblattansicht die Anzeige "#Fehler" nur in der Spalte ABR3

    2) ABR3 ist ein längeres berechnetes Textfeld a la ABR: x & y & wenn(a=b;c;d) --- hat aber NULL Ergebnis

    3) nein, kein Format eingestellt im Eigenschaftsblatt der Abfrage

    Nach einigen Tests komme ich zum Schluss, dass das "wenn..dann" in der Abfrage der Auslöser ist. Ich kann es nur noch nicht beseitigen, weil ABR3 ein (richtiges) NULL Ergebnis (aus einer anderen SELECT Abfrage) hat. Berechnet wird also nur, wenn es kein NULL Ergebnis hat. PS: die LEFT JOIN Abfrage hat früher auch immer funktioniert, erst jetzt nach einer größeren Umstellung geht es nicht mehr (Die Umstellung war strukturell, deshalb kann ich auch nicht mit Einzelschritten identifizieren, ab wann das Problem auftritt).
    Eine Ergänzung mit NZ( ) oder ein Voranstellen von " " bringt übrigens auch keine Lösung.
    Top of the page Bottom of the page


    Seite: < 7 8 9 10 11 12 ... 13 14 15 16 17 18 19 ... >
    Suche in diesem Forum
    Druckfreundliche Version
    (Alle Cookies von dieser Seite löschen.)