Suche | Statistiken | Benutzerliste | Access-FAQ | Datenschutz Foren
donkarl Forum
donkarl Forum ->  Themen -> Access -> Diskussion ansehen

Du bist als Gast eingelogt. ( Anmelden | Registrieren )
  • Vortrag zu Ribbons beim Access-Stammtisch Rhein-Ma...
  • Martin Asal16.01.15 20:02
  • "Berechnung läuft...", Navibereich nicht...
  • Lorenz13.01.15 20:06
       └ RE: "Berechnung läuft...", Navibereich... Lorenz16.01.15 09:13
          └ RE: "Berechnung läuft...", Naviberei... Karl Donaubauer16.01.15 17:24
  • Frontend / Backend Auswirkung auf Abfragen
  • SenSoden11.01.15 20:18
       └ RE: Frontend / Backend Auswirkung auf Abfragen Karl Donaubauer12.01.15 11:06
          └ RE: Frontend / Backend Auswirkung auf Abfragen SenSoden12.01.15 19:23
  • WENN-Funktion in Abfrageentwurf
  • r.gottier18.12.14 06:46
       └ RE: WENN-Funktion in Abfrageentwurf Karl Donaubauer18.12.14 14:34
          └ RE: WENN-Funktion in Abfrageentwurf r.gottier21.12.14 08:14
             └ RE: WENN-Funktion in Abfrageentwurf Karl Donaubauer22.12.14 09:47
                └ RE: WENN-Funktion in Abfrageentwurf r.gottier26.12.14 12:25
                   └ RE: WENN-Funktion in Abfrageentwurf Karl Donaubauer31.12.14 16:19
                      └ RE: WENN-Funktion in Abfrageentwurf r.gottier10.01.15 19:08
  • Access Stammtisch München am 08.01.2015 (Do.)
  • StefanWirrer07.01.15 17:39
  • ODBC
  • Marzer10.12.14 23:48
       └ RE: ODBC Karl Donaubauer18.12.14 14:57
          └ RE: ODBC Marzer22.12.14 14:15
             └ RE: ODBC PeterDoering24.12.14 11:30
  • Werte aus gleicher Abfrage und gleicher Spalte aus...
  • Greiff07.12.14 14:39
       └ RE: Werte aus gleicher Abfrage und gleicher Spal... wilo09.12.14 14:34
          └ RE: Werte aus gleicher Abfrage und gleicher Sp... Greiff09.12.14 18:18
       └ RE: Werte aus gleicher Abfrage und gleicher Spal... Karl Donaubauer18.12.14 15:10
          └ RE: Werte aus gleicher Abfrage und gleicher Sp... Greiff19.12.14 00:14
             └ RE: Werte aus gleicher Abfrage und gleicher ... Karl Donaubauer19.12.14 09:59
  • Access Stammtisch München am 11.12.2014 (Do)
  • StefanWirrer09.12.14 09:00
  • Abfrage bringt nicht die richtigen Werte
  • hot-pc02.12.14 23:07
       └ RE: Abfrage bringt nicht die richtigen Werte Greiff03.12.14 23:29
       └ RE: Abfrage bringt nicht die richtigen Werte Greiff03.12.14 23:32
          └ RE: Abfrage bringt nicht die richtigen Werte hot-pc04.12.14 08:09
             └ RE: Abfrage bringt nicht die richtigen Werte StefanWirrer04.12.14 14:04
  • merkwürdiges Verhalten einer Abfrage
  • Greiff01.12.14 11:17
       └ Auslöser ist bedingte Formatierung Greiff02.12.14 00:14
  • Bedingte Formatierung
  • horst.kattanek11.11.14 17:32
       └ RE: Bedingte Formatierung Marzer14.11.14 08:42
       └ RE: Bedingte Formatierung Greiff01.12.14 11:24
  • Scroll-Problem in Acc2013
  • MartinStelzmueller17.11.14 13:40
       └ RE: Scroll-Problem in Acc2013 Karl Donaubauer19.11.14 15:28
          └ RE: Scroll-Problem in Acc2013 MartinStelzmueller20.11.14 14:38
             └ RE: Scroll-Problem in Acc2013 Karl Donaubauer25.11.14 21:09
  • Access 2010 / (deutsche Version) - Datumsdarstellu...
  • MiHa14.11.14 12:11
       └ RE: Access 2010 / (deutsche Version) - Datumsdar... PeterDoering15.11.14 10:45
  • Office Design in Access
  • Marzer10.10.14 09:04
       └ RE: Office Design in Access pop29213.11.14 22:26
  • Objekte löschen
  • Marzer13.11.14 16:09
    hot-pc
    Gesendet: 02.12.14 23:07
    Betreff: Abfrage bringt nicht die richtigen Werte


    New user

    Beiträge: 2

    Hallo,

    ich habe mit einer Abfrage ein großes Problem. Ich versuche es mal so gut wie irgendwie möglich zu erklären, evtl. hat ja einer einen Tipp für mich.

    Ich habe ein Formular mit dem Namen "qbf_sammlung" welche keine Datenbankverbindung hat. In dem Formular gibt es folgende ungebundene Felder:

    - hersteller (= Kombinationsfeld)
    - typ (= Kombinationsfeld)
    - farbe (= Textfeld)


    Wenn ich nun in meinem Formular "qbf_sammlung" den Wert
    BMW im Feld hersteller
    330 bei Typ auswähle
    und dann über einen Button die Abfrage "abfrage_qbf_sammlung" ausführe, welche folgende Felder mit entsprechenden Filterkriterien beinhaltet,

    - hersteller = Wie Wenn(IstNull([Formulare]![qbf_sammlung]![hersteller]);"*";[Formulare]![qbf_sammlung]![hersteller])
    - typ = Wie Wenn(IstNull([Formulare]![qbf_sammlung]![typ]);"*";[Formulare]![qbf_sammlung]![typ])
    - farbe = hier ist kein Filterkriterium hinterlegt

    erhalte ich folgende Datensätze angezeigt:

    BMW 330 dunkelblau
    BMW 330 rot
    BMW 330
    BMW 330 grün

    was auch genau richtig ist bzw. so wie ich es haben will.

    Nun möchte ich aber dem User die Möglichkeit bieten, dass er nach der Farbe filtern kann und da beginnt mein Problem.
    Denn ich habe es schon mit folgenden Filterkriterien im Feld Farbe versucht und bekomme aber nie die richtigen Datensätze angezeigt.
    Denn entweder bekomme ich gar keine Datensätze oder zu viele.

    Wenn der User nach der Farbe rot filtert, dann möchte ich auch nur alle Autos haben, die im Feld Farbe den Wert rot stehen haben.

    Bei dem Filterkriterium Wie "*" & [Formulare]![qbf_sammlung]![farbe] & "*" Oder Ist Null
    bekomme ich zwar dann das rote Auto angezeigt, aber eben auch das Auto welches keine Farbe erfasst hat. Da der User aber auf rot filtert, sollen auch nur rote Autos angezeigt werden.

    Bei dem Filterkriterium Wie Wenn(IstNull([Formulare]![qbf_sammlung]![farbe]);ist null;"*" & [Formulare]![qbf_sammlung]![farbe] & "*")
    bekomme ich zwar nur das rote Auto angezeigt jedoch wenn man beim nächsten Filtern keinen Wert im Feld "farbe" im Formular qbf_sammlung erfasst, bekomme ich gar keine Datensätze mehr angezeigt.
    Ich möchte aber dann die selben Werte wie ganz oben angezeigt bekommen, als wenn kein Filterkriterium bei farbe hinterlegt wäre.

    Ich habe mir nun schon vier Abende bis weit über Mitternacht mit testen, umstellen der Filterkriterien und such im Internet nach einer Lösung um die Ohren gschlagen und komme leider nicht weiter.
    Hat hier evtl. jemand das selbe Problem und es schon mal gelöst.
    Bin über jeden Tipp dankbar.


    Achtung, ich kann aus dem Textfeld "farbe" kein Kombinationsfeld machen, es muss ein freier Text bleiben.

    Top of the page Bottom of the page


    Seite: < 28 29 30 31 32 33 ... 34 35 36 37 38 39 40 ... >
    Suche in diesem Forum
    Druckfreundliche Version
    (Alle Cookies von dieser Seite löschen.)