Probleme beim Umstieg auf Access 2013 / Access 2013RT
Karl Donaubauer
Gesendet: 15.09.15 13:35
Betreff: RE: Probleme beim Umstieg auf Access 2013 / Access 2013RT



Elite Veteran

Beiträge: 857
5001001001002525
Ort: Wien
Hallo, Martin!

thaenhusen - 08.09.15

Wir haben vor auf Access 2013 / Access 2013 Runtime umzusteigen und sind da gerade am Testen.
Dabei habe ich ein Problem mit Formularen, wenn ich hinten rum (VBA-Klasse oder Function) mit einem SQL-Passthorugh
gebauten Recordset die Datenherkunft im Formular tausche.

Funktioniert alles, aber der Fokus ist komplett weg. Ich muss erst mit der Maus in das Formular klicken, damit alles funktioniert.

In Access 2003 funktioniert der Code ohne Probleme.

Ich habe keine Erfahrung mit dem konkreten Problem (ich ändere Datenherkünfte immer vornerum ;-) . Das beste wäre natürlich vermeiden, aber für ob und wie müsste ich in der Anwendung herumtesten. Also beheben/wegtricksen:

Wenn ich richtig verstehe, liegt der "Wndows-Fokus" nicht mehr in Access bzw. in der aktuellen Anwendung.

Wenn dem so ist, könnte es zumindest mit einem kurzen Zwinkern abgehen, wenn ihr den Fokus per API wieder auf die aktuelle Access-Instanz oder auf das aktuelle Formular legt. Code dafür gibt's hier:
http://www.activevb.de/tipps/vb6tipps/tipp0214.html

Also Code in ein Standardmodul kopieren und dann z.B. mit dem aktuellen Formular versuchen (falls der Code im Formular-Klassenmodul steht):

ActivateWindow Me.hwnd

-----
Servus
Karl
*********
Access-Entwickler-Konferenz: https://www.donkarl.com/?aek
Access DevCon Vienna: https://www.donkarl.com/devcon
Access Forever: https://www.accessforever.org
Access News: https://www.youtube.com/playlist?list=PLVCeBbJIMDvdJ8ghMbEakJ6_EQyvy...
Top of the page Bottom of the page